Mikrotik Router DHCP Server Configuration


Basic Ip Address Configuration:

/ip address
add address=103.7.248.206/29 network=103.7.248.200 broadcast=103.7.248.207 interface=WAN
add address=10.10.10.1/24 network=10.10.10.0 broadcast=10.10.10.255 interface=LOCAL

Create an IP address pool:

/ip pool add name=DHCP-POOL ranges=10.10.10.1-10.10.10.254
Add a DHCP network which will concern to the network 10.10.10.0/24 and will distribute a gateway with IP address 10.10.10.1 to DHCP clients:

Add a DHCP server:


/ Ip dhcp-server enable 0
/ip dhcp-server add interface=LOCAL  addree-pool=DHCP-POOL
Ip dhcp-server network add address = 10.10.10.0/24 gateway = 10.10.10.1 dns-server = 8.8.8.8
comment="DHCP-POOL"

NAT Configuration:

/ip firewall nat
add chain=srcnat action=masquerade src-address=10.10.10.0/24 out-interface=WAN

Set Default Gateway:

/ip route
add dst-address=
0.0.0.0/0  gateway=103.7.248.201