Mikrotik Router PPPOE Server Configuration









Point-to-Point Protocol over Ethernet (PPPoE) is a network protocol and provide authentication,encryption and compression. PPPoE was developed by UUNET, Ericsson  and RouterWare  and is available as an informational RFC 2516.

Basic Ip Address Configuration :
/ip address
add address=103.7.248.206/29 network=103.7.248.200 broadcast=103.7.248.207 interface=WAN

Ip Pool setup for PPPOE user :
/ip pool
add name=PPPOE ranges=172.16.10.1-172.16.10.254
/ppp profile
add name="PPPOE" local-address=172.16.10.1 remote-address=PPPOE dns-server=8.8.8.8,4.4.4.4



Create a PPPOE  User:
/ppp secret
 add name=Test service=pppoe password=123 profile=PPPOE local-address=172.16.10.1 remote-address=172.16.10.3

Bandwidth Control Using PCQ Method:
/Queue type
add name=PPPOE_1M_DOWNLOAD kind=pcq pcq-rate=1M pcq-classifier=src-address
add name=PPPOE_1M_UPLOAD kind=pcq pcq-rate=1M pcq-classifier=dst-address
/queue simple

add name="Total" target-addresses=172.16.10.0/24 interface=all parent=none
      packet-marks="" direction=both priority=8
      queue=default-small/default-small limit-at=0/0 max-limit=0/0
      burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
      total-queue=default-small

add  name="PPPOE-1M User" target-addresses=172.16.10.0/24 interface=LOCAL
      parent=Total packet-marks="" direction=both priority=2
      queue=PPPOE_1M_UPLAOAD/PPPOE_1M_DOWNLOAD limit-at=0/0 max-limit=0/0
      burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
      total-queue=default-small
Lowest priority is better than other, If use this type of queue then we can easy to manage bandwidth a group of client

/ip firewall nat
add chain=srcnat action=masquerade src-address=172.16.10.0/24 out-interface=WAN


IP Route Configuration:

/ip route
add dst-address=0.0.0.0/0 gateway=103.7.248.201